15.2. Requirements

In order to run Pegasus workflows via Jupyter the following software packages are required:

  1. Python 2.7 or superior (Jupyter requires version 2.7+)

  2. Java 1.6 or superior

  3. Pegasus 4.8.0 or superior (submit node)

  4. Jupyter (see installation notes)