3.2. Optional Software

  • Globus 5.0 or higher. Globus is only needed if you want to run against grid sites or use GridFTP for data transfers. See http://www.globus.org/ for more information.

  • psycopg2. Python module for PostgreSQL access. Only needed if you want to store the runtime database in PostgreSQL (default is SQLite)

  • python-amqplib. Python module for sending workflow events to RabbitMQ. This is optional, and has to be enabled in the Pegasus workflow configuration.